Product Attachment Extension

Product Specification

The Product Attachment Magento 2 extension, developed by PIT Solutions, offers
advanced attachment management features for your Magento store. With the added
capability of supporting demo and trial versions, this extension empowers merchants
to provide a comprehensive product experience to customers by allowing them to
upload and access various file types, including demos, trials, user manuals, and more,
directly from the product pages.

This version, which also supports, takes it a step further by allowing administrators to
control attachment downloads and restrict based on customer groups and stores. This
capability empowers merchants to customize the attachment experience for different
customer segments and store views.

The extension enables administrators to effortlessly upload files or use URLs, offering
flexibility in attaching content, and further supports the convenience of multiple file
uploads.

The administrators can efficiently select common documents from the list of previously
uploaded attachments, reducing redundancy and optimizing file storage.

With a simple click, administrators can conveniently enable or disable an attachment,
streamlining the management of its functionality.

The extension empowers administrators to effectively manage frontend view,
position, titles and content display, providing them with control over how attachments
are presented to customers.

Features

Certainly, here is a comprehensive list of the features included in the extension.

e Attachment Upload: Admin users can upload a variety of file types, including
demos, trials, PDFs, images, videos, and more to associate them with specific
products.



Hyva Compatibility: Fully compatible with the Hyva theme. It utilizes
lightweight, fast-loading and modern frontend components to seamlessly
integrate with the Hyva framework.

Product-Attachment Association: Admin users can link attachments to one or
multiple products, ensuring relevant information is displayed on product pages.

Frontend Display and Interaction: Dedicated attachment section on product
pages allows customers to easily download, view, or interact with attached
files, including demos and trials.

User-Friendly Icons and Visuals: Automatically assigned icons or thumbnails
based on attachment types enhance quick content identification.

Demo and Trial Support: Admin users can upload demo and trial versions of
products, enabling customers to preview and experience product functionality.

Multi-Language and Responsive Design: Support for multiple languages and
responsive design ensure global access to product information and
attachments on various devices.

Attachment Management and Permissions: Admin users can disable or delete
attachments and customize user permissions for attachment management.

Customer Group Restrictions: Admin users can restrict attachment downloads
based on customer groups, tailoring attachment availability.

File Upload and URL Support: Admins can upload files directly or attach URLs,
offering versatile options for managing attachments.

Multiple File Uploads: Conveniently supports the upload of multiple files at
once, improving efficiency in attaching content.

Reuse Common Documents: Admins can easily select frequently used
documents from the previous attachment list, reducing redundancy and
optimizing file storage.

Enable/Disable with One Click: Administrators can effortlessly enable or
disable the extension's functionality with a single click, simplifying
management.



¢ Frontend View Customization: Admin users have the capability to manage
frontend view positions, titles, and content display, offering greater control
over attachment presentation to customers.

Installation

To install the Product Attachment Extension for Magento 2, follow the steps below.
Please ignore this step if you are installing the extension using composer.

1) Download the extension.

2) Access your web server directories and unzip and upload the content of the zip file
to app/code/Pits/ ProductAttachment directory.

3) Run the following commands from the SSH terminal of the server to complete the
installation.

e Enable the module - php bin/magento module:enable Pits_ProductAttachment
e Update the database schema - php bin/magento setup:upgrade

e Generate and pre-compile classes - php bin/magento setup:di:compile

e Deploy static files - php bin/magento setup:static-content:deploy

e Clear the cache - php bin/magento cache:flush

Admin Panel Configuration

Navigate to Stores -> Configuration -> Pits Extensions -> Product Attachments



General Configuration

Module E_n__a_l:_ll:g Yes .

Display File Size Yes -
File Size l?_tg.c_ls?n Megabytes -
Show Downloads Count

Yes S

Sc_»_r_t_?rd_er_ Alphabetical v

Attachment Tab Title | |

Used for product pages. If empty, the ‘Attachments’ title will be used

Maximum File Size Allowed 5

If empty or greater than server limitation, server limitation will be applied. php.ini memory size
format can be used (for example, "100k", "1m", etc).

FronLend_:F:?ilfl.Er! View in Tab .
Product page attachment position tab/ after action buttons.
Tab Sort Order |

Product page attachment tab sort order. Applicable only in the Luma theme.

Figure 1 - Admin panel configuration

In Figure 1, the admin configurations of the extension reveal a set of fields, each
serving a specific purpose in tailoring the extension's functionality. These fields will be
elucidated to facilitate a better grasp of how to fine-tune the extension to meet
specific requirements. The fields are:

Module Enable - Enable / Disable module.
Display File Size - Enable / Disable showing file size in frontend.

File Size Precision - If Display File Size is enabled, the file size will be shown in
frontend and the admin can choose which precision should use for that, the options
are:

e Auto - System will automatically choose appropriate precision based on the
file size

e Kilobytes - All the file size will be shown in Kb

e Megabytes - All the file size will be shown in Mb

Show Downloads Count - Enable / Disable showing the downloads count for each
attachment in frontend.

Sort Order - Choose the attachments listing order in frontend. The options are:

e Alphabetical - Sort the attachment list in alphabetical order.
e Upload Date - Uploaded date wise Sort will apply to the attachment list.



e Size - File size wise Sort will apply to the attachment list.
e Downloads Count - The attachment list will be sort as per the number of
downloads

Attachment Tab Title - The admin can change the attachment tab title in the product
details page, by default it will be Attachments

Maximum File Size Allowed - The admin can configure the maximum allowed size of
the file being uploaded.

Frontend Position - The admin can change the view position of the attachment block
in the product details page. The options are:

e View in Tab - The attachment block will show in a tab.
e View in Info Block - The attachment block will be shown below add to cart
button inside info block

Note: If you are using “Product -- Full Width” layout, the tab view will not be visible in
the frontend. So, if you choose Frontend Position as ‘View in Tab'’ it will not show
product attachments. That case, in the extension configuration, you can use “Frontend
position” as “View in info block” option instead of “View in Tab” to see the product
attachment for products having “Product -- Full Width” layout.

You can change the product layout from product edit form -> design tab -> layout.

Design

Layout Product -- Full Width v
Display Product Options In Product Info Column v

Custom Layout Update No update | w

Figure 2 shows Catalog Product Add/Edit Form Design Tab

Tab Sort Order - If the Frontend Position is View in Tab, the admin can add sort order
for the attachment tab. Admin user can change the position of the attachment tab.
Expected numbers will be like 10, 20, 100 etc. This is only applicable in Luma theme.

Product Form Attachments Tab

Navigate to Catalog-> Products-> Edit -> Product Attachments
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Figure 3 - Catalog Product Add/Edit Form Product Attachments Tab

Figure 3 displays the Attachments tab within the product Add/Edit page on the
backend, featuring options to upload new attachments, select from a list of previously
uploaded items, and a dedicated attachments grid. In the following, we will provide a
detailed explanation for each of these buttons and grid titles.

Upload Attachments - To upload new attachments.

Choose from List - Choose common attachments from the previously uploaded list.

ID - Entity Id of attachment.

Name - Title of attachment.

File Name - File name with directories from media directory.
Store View - Shows the specific Store View

Type - File extension.

URL - URL, if it is not a file upload.

Date Modified - Date of last modification of attachment.

Is Active - Is the attachment active.

Actions - Download, change status, remove are the actions available.

Product Form Attachments Upload

Navigate to Catalog-> Products-> Edit -> Product Attachments-> Upload Attachments



Attachment Information

Download Limit (File/URL)
Choose Attachment Type File
Upload File(s) Upload

Choose Customer Groups NOT LOGGED IN

»

Choose Store Views All store Views

Enable/Disable No

Figure 4 - Catalog Product Add/Edit Form Add New Attachment

In Figure 4, which showcases the "Add New Attachment" form, we are providing an
explanation of the fields present on the image.

Attachment Title - Title of attachment. This title will be file name or url if user leaves
this field empty.

Attachment Description - Description of the attachment.

Download Limit (File/URL) - Limit Downloads count - unlimited, if left empty. If an
attachment reaches the limit, it will be removed from frontend.

Choose Attachment Type - Choose attachment type URL/ File.
Upload File - Multi file upload input.
URL - URL, if it is not a file upload.

Choose Customer Group - Choose customer group that the group can download the
attachment. Other groups also can view the attachment but cannot download.

Choose Store Views - Choose store view of the attachment.

Enable/ Disable - Enable or Disable the attachment.



»
Product Form Attachments Choose from List

Navigate to Catalog-> Products-> Edit -> Product Attachments -> Choose from List

Choose From List X

Cancel Add Selected Attachments
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Figure 5 - Catalog Product Add/Edit Form Choose from Previous List with Multiselect
action

Figure 5 illustrates the "Choose from List" action, displaying a grid containing
previously uploaded attachments with multiselect option. Below, we will elucidate the
titles within this grid.

Id - Entity Id of attachment.

Name - Title of attachment.

URL - URL, if it is not a file upload.

File Name - File name with directories from media directory.
Type - File extension.

Date Modified - Date of last modification of attachment.
Store View - Attachment’s store view.

Enable - Attachment is active or not.

How It Works in Frontend

When customers navigate to a product page, they will notice a dedicated section that
displays attachments associated with that specific product. The position of the
attachments section will change depending on the admin configuration, from tab view
to info block.
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Figure 6 - Product details page attachments in Tab View
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Figure 7 - Product details page attachments in Info Block

Note: The Store View and Type will be added to the Admin Listing Grid only after

saving the attachment.

Technical Requirements / Compatible with:

Magento Open Source (CE) 2.4.4-2.4.8

Supported Languages



English, German, French and easily customizable for other Magento supported
language packs.

Change Log / Release Notes
Version:1.0.4: July 2025

e Compatible with Hyva theme
e Compatible with Open Source (CE): 2.4.4-2.4.8

Version: 1.0.3: May 2025

e Compatible with Open Source (CE): 2.4.8

Version: 1.0.2: July 2024
e Compatible with Open Source (CE): 2.4.7-p1

Version: 1.0.1: November 2023

e Compatible with Open Source (CE): 2.4.6-p3
Version: 1.0.0: August 2023
e |Initial Version

Support

If you have questions, use our contact form in webshopextension.com.
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